HDU 6055 Regular polygon【几何】

题目来戳呀
和poj2002也是很类似的~poj2002

Problem Description

On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.

Input

The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)

Output

For each case, output a number means how many different regular polygon these points can make.

Sample Input

4
0 0
0 1
1 0
1 1
6
0 0
0 1
1 0
1 1
2 0
2 1

Sample Output

1
2

题意:

给你一些整数点,判断这些整数点能否构成不同的正多边形。

想法:

1.只有正方形才能分解成等腰直角三角形能用整数点表示,所以题目就是找正方形个数。具体证明整数点只能存在正方形参考杨景钦在2017国家集训队的论文。

2.直接用四个点六条边来判断边是否相等,对角边是否满足勾股定理会超时。

3.综上我们选择两个点来求出能构成正方形的另外两个点的坐标,判断这两个点的坐标是否已经给出,,如图:
这里写图片描述

tips:
1.选择的两个点是一条直角边上的点,不是对角边的顶点。
2.两个点能同时在左边和右边分别构成正方形,所以要判断两次。
3.因为坐标可能为负,标记时用的数组,所以要+300以上。
4.两个点能做四次直角边,所以最后答案要除以4。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int vis[1500][1500];
struct point
{
    int x,y;
} p[1500];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int ans=0;
        memset(vis,0,sizeof vis);
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].x+=300;
            p[i].y+=300;
            vis[p[i].x][p[i].y]=1;
        }
        for(int i=0; i<n; ++i)
        {
            for(int j=i+1; j<n; ++j)
            {
                int disx=p[j].x-p[i].x;
                int disy=p[j].y-p[i].y;
if(vis[p[i].x+disy][p[i].y-disx]&&vis[p[j].x+disy][p[j].y-disx])
                    ans++;
if(vis[p[i].x-disy][p[i].y+disx]&&vis[p[j].x-disy][p[j].y+disx])
                    ans++;
            }
        }
        printf("%d\n",ans/4);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值