hdoj-5120-Intersection【数论】

Intersection

Time Limit: 4000/4000 MS (Java/Others) Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 964 Accepted Submission(s): 368


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778

Source

Recommend
liuyiding | We have carefully selected several similar problems for you: 5338 5337 5336 5335 5334

注意: Pi 不能自己写,要用acos(-1.0) ,在这里WA了好多次

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
double dis,R,r;
struct point{
	double x,y;
}a,b;
const double pi=acos(-1.0);
double S(double r1,double r2){
	if(dis>=(r1+r2)) return 0; //外切或不相交 
	double s1,s2,sit1,sit2; 
	if(dis<=fabs(r1-r2)){  //内切或内含 
		r1=min(r1,r2);
	    return pi*r1*r1; 
	}
	s1=(r1*r1+dis*dis-r2*r2)/(2*r1*dis);
	s2=(r2*r2+dis*dis-r1*r1)/(2*r2*dis);
    sit1=acos(s1);
    sit2=acos(s2);
	return sit1*r1*r1+sit2*r2*r2-r1*dis*sin(sit1);
	 
}
int main(){
	int t,cas=0;
	scanf("%d",&t);
	while(t--){
		++cas;
		scanf("%lf%lf",&r,&R);
		scanf("%lf%lf",&a.x,&a.y);
		scanf("%lf%lf",&b.x,&b.y);
	    dis=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
	    if(fabs(dis)<1e-7){
	    	printf("Case #%d: %.6lf\n",cas,pi*(R*R-r*r));
	    	continue;
	    }
		double ss=0;
		ss=S(R,R);
		ss-=2*S(R,r)-S(r,r);
		printf("Case #%d: %.6lf\n",cas,ss);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值