题目1014:排名

题目1014:排名

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:7399

解决:2191

题目描述:
    今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
输入:

    测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。 
    当读入的考生人数为0时,输入结束,该场考试不予处理。

输出:

    对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。

样例输入:
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
样例输出:
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

思路:

1 开始使用HashMap方式,时间各种超,直接建立私有类

2 用BufferedReader 代替 Scanner 加快输入速度

3 最终AC

  1014 Accepted 133880KB 3787B 1840MS


参考代码:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;

public class Main {
		
	 private static class Student implements Comparable<Student> {
	        String id;
	        int mark;
	  
	        public Student(String id, int mark) {
	            this.id = id;
	            this.mark = mark;
	        }
	  
	        public String toString() {
	            return (this.id + " " + this.mark);
	        }
	  
	        @Override
	        public int compareTo(Student s1) {
	            if (s1.mark != this.mark)
	                return (s1.mark - this.mark);
	            else
	                return (this.id.compareTo(s1.id));
	        }
	    }
	
	
	
	public static void main(String arg[]) throws IOException{
		
		//Scanner sc = new Scanner(System.in);
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		
		
		//while(sc.hasNext()){
		while(true){
			//Integer numofstu = sc.nextInt();
			//if(numofstu ==0 ) break;
			//Integer numofproblem = sc.nextInt();
			//Integer scoreline = sc.nextInt();
			String s = br.readLine();
			//System.out.println(s);
			if(s==null) break;
			String[] tempNum = s.split(" ");
			Integer numofstu=Integer.parseInt(tempNum[0]);
			if(numofstu ==0) break;
			Integer numofproblem=Integer.parseInt(tempNum[1]);
			Integer scoreline=Integer.parseInt(tempNum[2]);
			
			List<Integer> list1 = new ArrayList<Integer>();
			//接收每题分数
			s=br.readLine();
			tempNum = s.split(" ");
			for(int i=0;i<tempNum.length;i++){
				list1.add(new Integer(tempNum[i]));
				//list1.add(sc.nextInt));
			}
			//接收回车
			//String temp = sc.nextLine();
			
			//接收学生资料
			//Map<String, Integer> map1 = new HashMap<String, Integer>();
			List<Student> students = new ArrayList<Student>();
			
			for(int i=0;i<numofstu;i++){
				Integer score = 0;
				//String str = sc.nextLine();
				String str=br.readLine();
				String[] str1 = str.split(" ");
				for(int j=2;j<str1.length;j++){
					Integer num = Integer.parseInt(str1[j]);
					score += list1.get(num-1);
				}
				//map1.put(str1[0],score);
				if(score>=scoreline) students.add(new Student(str1[0], score));
			}
			
			System.out.println(students.size());
			Collections.sort(students);
			
			for(Student i :students){
				System.out.println(i.toString());
			}
			
			
			students.clear();
	           
			
		/*	//System.out.println(map1);
			//排序
			List<Map.Entry<String, Integer>> ScoreList =new ArrayList<Map.Entry<String, Integer>>(map1.entrySet());
			Collections.sort(ScoreList, new Comparator<Map.Entry<String, Integer>>() {   
			    public int compare(Map.Entry<String, Integer> o1, Map.Entry<String, Integer> o2) {      
			       Integer x = o2.getValue() - o1.getValue();
			       if(x==0) return (o1.getKey()).toString().compareTo(o2.getKey());
			       else return x; 
			      //  return (o1.getKey()).toString().compareTo(o2.getKey());
			    }
			});
			//选择输出
			
			Integer count = 0;//人数标志;
			for(int i=0;i<ScoreList.size();i++){
				if(ScoreList.get(i).getValue()>= scoreline)
					{
					count++;
					}
				else break;
			}
			System.out.println(count);
			for(int i=0;i<count;i++){
				if(ScoreList.get(i).getValue()>= scoreline)
					{
					System.out.println(ScoreList.get(i).toString().replace("=", " "));
					}
				else break;
			}*/
			
		
			
		}
	}	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值