Strange fuction HDU - 2899

Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534

三分模板题,二分常用于解决单调递增或递减的函数,三分则用于解决抛物线型的函数

#include <iostream>
#include <stdio.h>
using namespace std;
double y;
double check(double a){
    double b;
    b=6*a*a*a*a*a*a*a+8*a*a*a*a*a*a+7*a*a*a+5*a*a-y*a;
    return b;
}

int main()
{
    int T;
    double low,high,mid,mmid,s1,s2;
    scanf("%d",&T);
    while(T--){
        scanf("%lf",&y);
        low=0;high=100;
        while(high-low>1e-8){
            mid=(low+high)/2;
            mmid=(mid+high)/2;
            s1=check(mid);
            s2=check(mmid);
            if(s1<s2){
                high=mmid;
            }else{
                low=mid;
            }
        }
        printf("%.4lf\n",s2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值