kuangbin 数论基础 C题

C - Aladdin and the Flying Carpet

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2

题解:

一开始想到用筛法求因子个数,但是题目数量达到1e12,太大。
后来想到用唯一分解定理,只要求出所有因子个数,除以2.暴力枚举b之前的因子个数,相减就是答案。
TLE了好几次,原因是没有考虑到一种特殊情况,
当b>a*a,应当直接输出0即可。因为a最小因子肯定是比sqrt(a)要大的,不存在这种情况。

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const int maxn = 1e6+100;
typedef long long LL;
bool notprime[maxn];
int prime[maxn+1];

LL a,b;
void getprime()
{
   memset(notprime,false,sizeof(notprime));
   notprime[0]=notprime[1]=true;
   memset(prime,0,sizeof(prime));
   for(int i=2;i<maxn;i++)
   {
       if(!notprime[i]) prime[++prime[0]]=i;
       for(int j=1;j<=prime[0]&&prime[j]<=maxn/i;j++)
       {
           notprime[prime[j]*i]=true;
           if(i%prime[j]==0) break;
       }
   }

}


LL getfactor()
{
    LL cnt=0;
    LL sum=1;
    for(int i=1;i<=prime[0]&&prime[i]*prime[i]<=a;i++)//注意这里
    {
      if(a%prime[i]==0)
      {
        while(a%prime[i]==0)
        {
            cnt++;
            a/=prime[i];
        }
        sum*=(cnt+1);
        cnt=0;
      }

        if(a==1) break;
    }

    if(a!=1) sum*=2;

    return sum/2;
}

int main()
{
    getprime();
    int T;
    scanf("%d",&T);
    int ks=1;
    while(T--)
    {
       scanf("%lld%lld",&a,&b);
       if(a<b*b)//关键的代码,因为这个超时很多次
       {
           printf("Case %d: 0\n",ks++);
            continue;
       }
       LL num=0;
       for(LL i=1;i<b;i++)
       {
           if(a%i==0)
             num++;
       }

        LL total = getfactor();

        printf("Case %d: %d\n",ks++,total-num);


    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值