POJ 1442 Black Box

11 篇文章 0 订阅
3 篇文章 0 订阅
Black Box
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8627 Accepted: 3537

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 
N Transaction i Black Box contents after transaction Answer 

      (elements are arranged by non-descending)   

1 ADD(3)      0 3   

2 GET         1 3                                    3 

3 ADD(1)      1 1, 3   

4 GET         2 1, 3                                 3 

5 ADD(-4)     2 -4, 1, 3   

6 ADD(2)      2 -4, 1, 2, 3   

7 ADD(8)      2 -4, 1, 2, 3, 8   

8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   

9 GET         3 -1000, -4, 1, 2, 3, 8                1 

10 GET        4 -1000, -4, 1, 2, 3, 8                2 

11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

Sample Output

3
3
1
2

题目大意:输入n,m 下一行给你n个数A1...An依次进行插入排序,然后给你m个数 u1...um要求你输出进行第ui次插入时候,序列中第i小的数是多少

思路使用两个优先队列   一个从小到大,一个从大到小,从小到大的队列Now储存第i+1大到第ui大的数,另外一个从大到小队列Del储存最小到第i小的数,每次插入操作的时候将A[i]插入到Del中然后将Del的队顶插入到Now中

例如 第5次插入前
Del : 1 ,-4 Now:2, 3
之后插入 8
 Del:8,1,-4 Now:2,3
Del的队头出队到Now中
Del 1,-4 Now:2,3,8
如果这次要查询的话直接输出Now的队头2然后将2插入到Del的队头就可以了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
#define inf 0xffffff
#define maxn 30010

int A[maxn],u[maxn];

int main()
{
    int n, m;
    while(cin>>n>>m)
    {
        for(int i = 1; i <= n; i++)
            scanf("%d",&A[i]);
        for(int i = 0; i < m; i++)
            scanf("%d",&u[i]);
        int top = 0;

        priority_queue<int,vector<int>,greater<int> > Now;
        priority_queue<int> Del;
        while(!Now.empty()) Now.pop();
        while(!Del.empty()) Del.pop();

        for(int i = 1; i <= n; i++)
        {
            if(Del.empty() || A[i] >= Del.top()) //一个优化当Del为空就代表还没有查询或者
                Now.push(A[i]);<span style="white-space:pre">			</span> //<span style="font-family: 'Times New Roman', Times, serif;">插入数据大于第i小的数可以直接插入节约20ms</span>
            else
            {
                Del.push(A[i]);
                int x = Del.top();
                Del.pop();
                Now.push(x);
            }
            while(i == u[top] && top < m)
            {
                int x = Now.top();
                Now.pop();
                printf("%d\n",x);
                Del.push(x);
                top++;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值