数论——欧拉函数(zoj(1906Relatives))

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.


Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.


Output

For each test case there should be single line of output answering the question posed above.


Sample Input

7
12
0


Sample Output
5

4

题目大意:

给定一个整数,求出小于这个整数并与其互素整数的个数。

解题代码:

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int oula(int n)
{
	int res=n;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
		n/=i;
		res=res-res/i;
		while(n%i==0)
		n=n/i;
			
		}
	}
	if(n>1)
	res=res-res/n;
	return res;
}
int main()
{
	int n,m,k,l;
	while(scanf("%d",&n)&&n!=0)
	{
	printf("%d\n",oula(n));	
	}
	
	
}


欧拉函数:

int oula(int n)
{
	int res=n;
	for(int i=2;i*i<=n;i++)
	{任何和数素因子均不大于n的平方根:
		if(n%i==0)
		{
		n/=i;
		res=res-res/i;(筛去含有该因子的所有数.
		while(n%i==0)
		n=n/i;
			
		}
	}
	if(n>1)
	res=res-res/n;
	return res;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值