HDU1506 Largest Rectangle in a Histogram 单调栈

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15428    Accepted Submission(s): 4483


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 

Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 

Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 

Sample Input
  
  
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 

Sample Output
  
  
8 4000
 

Source
 


题意:如图所示,求最大面积

思路:单调栈解决。每来一个数就构造一个node,node里有两个元素,一个是这个node的高h,另一个是他的次序id。如果新来的node高度大于前一个node那么直接就放进去好了,如果新来的node小于前一个node,那么就要把他前面所有比他小的node都拿出来,pop的时候把面积算一下,跟ans进行一次max。这里需要注意一下,新加进来的node的id不能随便搞,必须要跟最后一个pop出去的那个id相等,不然就不对了,因为这个我还WA了一发。然后需要注意一下开头和结尾,我都人为的加入了两个高度为0的矩形,这样能把所有有效数据取出来,恩就是这样。


#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <iomanip>
#include <time.h>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff;
const int MAX_N=10000;
int N;
long long h;
struct node{
    long long id,H;
    node(long long ID,long long h){
        id=ID;
        H=h;
    }
};
stack<node>s;

long long ans;
int main(){
    while(scanf("%d",&N)&&N!=0){
        ans=0;
        while(!s.empty()){
            s.pop();
        }
        s.push(node(0,0));

        int curid;
        for(int i=1;i<=N+1;i++){
            if(i!=N+1)scanf("%d",&h);
            else{
                h=0;
            }
            node newn=s.top();
            node cur=node(i,h);
            if(h>=newn.H){
                s.push(cur);
            }
            else{
                while(!s.empty()){
                    node newn=s.top();
                    if(newn.H<=cur.H){
                        s.push(node(curid,h));
                        break;
                    }
                    else{
                        s.pop();
                        curid=newn.id;
                        ans=max(ans,(i-newn.id)*newn.H);
                    }
                }

            }

        }
        cout<<ans<<endl;

    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值