1043. 输出PATest(20)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee


#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	char a[10000];
	int aa[6];
	for(int i=0;i<6;i++)
	{
		aa[i]=0;
	}
	cin.getline(a,10000,'\n');
	for(int i=0;i<strlen(a);i++)
	{
		if(a[i]=='P')
		{
			aa[0]++;
		} 
		if(a[i]=='A')
		{
			aa[1]++;
		} 
		if(a[i]=='T')
		{
			aa[2]++;
		} 
		if(a[i]=='e')
		{
			aa[3]++;
		} 
		if(a[i]=='s')
		{ 
			aa[4]++;
		} 
		if(a[i]=='t')
		{
			aa[5]++; 
		} 	
	}
	int max=0;
	for(int i=0;i<6;i++)
	{
		if(aa[i]>max)
		{
			max=aa[i];
		}
		
	}
	while(max!=0)
	{
		if(aa[0]!=0)
		{
			cout<<"P";
			aa[0]--; 
		}
		if(aa[1]!=0)
		{
			cout<<"A";
			aa[1]--; 
		}
		if(aa[2]!=0)
		{
			cout<<"T";
			aa[2]--; 
		}
		if(aa[3]!=0)
		{
			cout<<"e";
			aa[3]--; 
		}
		if(aa[4]!=0)
		{
			cout<<"s";
			aa[4]--; 
		}
		if(aa[5]!=0)
		{
			cout<<"t";
			aa[5]--; 
		}	
		max--;
	}
	
 } 


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值