hdu 5494 Card Game(BC水题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5494

Card Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 384    Accepted Submission(s): 256


Problem Description
Soda and Beta are good friends. They are going to play a card game today. Soda has n cards with number a1,a2,...,an while Beta has n cards with number b1,b2,...,bn .

First, they choose a number m no larger than n . Then they both randomly select m cards from their own n cards. The one with larger sum of the selected cards will win. Soda wants to know if he can always win no mater what cards will be randomly selected from him and Beta.
 

Input
There are multiple test cases. The first line of input contains an integer T(1T100) , indicating the number of test cases. For each test case:

The first line contains two integer n and m (1mn500) . The second line contains n integers a1,a2,...,an (1ai1000) denoting Soda's cards. The third line contains n integers b1,b2,...,bn (1bi1000) denoting Beta's cards.
 

Output
For each test case, output "YES" (without the quotes) if Soda can always win, otherwise output "NO" (without the quotes) in a single line.
 

Sample Input
  
  
2 3 1 4 5 6 1 2 3 5 2 3 4 7 8 9 3 4 5 2 3
 

Sample Output
  
  
YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5503  5502  5501  5499  5498 

题目大意:Soda和Beta两个人每个人都有n张卡片,并且每人从中选出m张。要求输出的是Soda无论选什么加起来的和都比Beta大就输出YES,否则输出NO~~     大笑

解题思路:先排序,将Soda中前m个小的加起来,Beta中后m个大的相比较即可!

 
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    int a[1010],b[1010];
    while (T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for (int i=1;i<=n;i++)
        {
            scanf ("%d",&a[i]);
        }
        sort(a+1,a+n+1);
        int sum1=0;
        int sum2=0;
        for (int i=1;i<=m;i++)
            sum1+=a[i];
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+n+1);
        for (int i=n;i>n-m;i--)
            sum2+=b[i];
        if (sum1>sum2)
            printf ("YES\n");
        else
            printf ("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值