POJ 3723 Conscription(Kruskal算法)

Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4931 Accepted: 1704

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

//Kruskal算法

//本来要用两个集合来区分男生和女生,后来才发现不用,将男生的编号加上女生的人数就可以区别开了,

//这样男生和女生的号码都是连续的,而且只要有关系的,一定是一男一女,这样也符合,然后将有关系

//不断加入集合,另外就是,本来是要求最小生成树的,这就要求每对关系的权值被10000减,那么我们

//可以先求出最大生成树,然后再将总的10000*(m+n)减去所得最大生成树的权值,还有就是第一次

//被买的男生或女生一定要花费10000,之后再根据关系选择其他!!

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 20001
struct point {
    int u, v, w;
}pnt[50001];

int set[N], rank[N];

bool cmp(struct point p1, struct point p2) {
    return p1.w > p2.w;
}

void make_set(int n) {
    for(int i = 0; i <= n; i++) {
        set[i] = i;
        rank[i] = 1;
    }
}

int find_set(int x) {
    int j, k, r;
    r = x;
    while(r != set[r]) {
        r = set[r];
    }
    k = x;
    while(k != r) {
        j = set[k];
        set[k] = r;
        k = j;
    }
    return r;
}

void merge(int x, int y) {
    int xx = find_set(x);
    int yy = find_set(y);
    if(xx == yy) return;
    if(rank[xx] > rank[yy]) {
        set[yy] = xx;
        rank[xx] += rank[yy];
    } else {
        set[xx] = yy;
        rank[yy] += rank[xx];
    }
}

int main()
{
    int m, n, r, i, total, t;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d%d", &n, &m, &r);
        for(i = 0; i < r; i++) {
            scanf("%d%d%d", &pnt[i].u, &pnt[i].v, &pnt[i].w);
            pnt[i].v += n;
        }
        make_set(n+m); total = 0;
        sort(pnt, pnt+r, cmp);
        for(i = 0; i < r; i++) {
            if(find_set(pnt[i].u) != find_set(pnt[i].v)) {
                total += pnt[i].w;
                merge(pnt[i].u, pnt[i].v);
            }
        }
        printf("%d\n", 10000*(n+m)-total);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值