A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 204943 Accepted Submission(s): 39396Problem DescriptionI have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.Sample Input2 1 2 112233445566778899 998877665544332211
Sample OutputCase 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110import java.math.BigInteger;
import java.util.Scanner;
public class Main {
public static void main(String[] args)
{
Scanner cin= new Scanner(System.in);
BigInteger a,b,c;
int t = cin.nextInt();
for(int cas = 1;cas<=t;++cas)
{
a = cin.nextBigInteger();
b = cin.nextBigInteger();
c=a.add(b);
System.out.println("Case "+cas+":");
System.out.println(a + " + " + b + " = " + c);
if(cas<t) System.out.println();
}
}
}第一次用JAVA,纪念一下。
A + B Problem II
最新推荐文章于 2014-08-16 19:56:53 发布