POJ 1156 Palindrome (最长公共子序列)

Palindrome
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 51635
Accepted: 17770

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

IOI 2000


#include <iostream>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std;
#define M 5050
char str1[M],str2[M];
short int vis[M][M],n;  //不加short就挂的死死的。
int max(int x,int y)    
{   if(x>y)
	return x;
return y;
}

int str(char str1[],char str2[])
{   
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			if(str1[i]==str2[j])
			{
				vis[i][j]=vis[i-1][j-1]+1;
			}
			else
			{
				vis[i][j]=max(vis[i-1][j],vis[i][j-1]);
			}
		}
/*		for(i=0;i<=n;i++)
		{
			for(j=0;j<=n;j++)
				printf("%d",vis[i][j]);
			printf("\n");
		}
*/
				return vis[n][n];
}
//这一串就是判断顺序和逆序的最长公共子序列的长度。估计1000+MS就是因为这里。
int main()
{
	int t,i,j;
	while(scanf("%d",&n)!=EOF)
	{   memset(vis,0,sizeof(vis));
        memset(str1,'0',sizeof(str1));
        memset(str2,'0',sizeof(str2));
		getchar();
		for(i=1,j=n;i<=n;i++,j--)
		{
		   scanf("%c",&str1[i]);
		   str2[j]=str1[i];
		}
		getchar();  //开始没这个,所以各种坑都出现了。
        t=str(str1,str2);   
		printf("%d\n",n-t);
	}
	return 0;
}
看了别人的解题报告,才知道有这个方法,然后就是一个裸的好似叫manachure算法的东西..
不知道是什么...好像要搞滚动数组...不明觉厉...
代码简单,原理复杂,不知道是谁想出来的解题方法...
根本看不出来是求公共子序列的题。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值