HDU 1242 Rescue (BFS+优先队列)

Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

因为有守卫的存在,所以先入队的时间未必小,我们要输出时间小的,就要先处理时间小的。
所以用到了优先队列。时间小的优先处理。
#include <iostream>
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
#define M 210
struct node{
int x,y,time;
 friend bool operator<(node a,node b)  //优先队列自定义(我认为是这样)
 {
     return a.time>b.time;             //和sort相反a.time>b.time的时候b先入队,也就是时间小的先入队。
 }
};
int n,m,vis[M][M];
char map[M][M];
int dis[4][2]={1,0,0,1,-1,0,0,-1};
int DFS(int x,int y,int time)
{
    int i,j;
  node t,temp;
  memset(vis,0,sizeof(vis));
  t.x=x;t.y=y;t.time=time;
  priority_queue<node>Q;                  //定义一个优先队列。
  Q.push(t);
  vis[t.x][t.y]=1;
  while(!Q.empty())
  {
      t=Q.top();
      Q.pop();
      if(map[t.x][t.y]=='a')
      {
          return t.time;
      }
      for(i=0;i<4;i++)
      {
          temp.x=t.x+dis[i][0];
          temp.y=t.y+dis[i][1];
          temp.time=t.time+1;
          if(temp.x>=0 && temp.x<n && temp.y>=0 && temp.y<m)           //先判断越没越界。
            if(!vis[temp.x][temp.y] && map[temp.x][temp.y]!='#')       //再判断合不合法,要不然会报错。
          {
              if(map[temp.x][temp.y]=='x')                             //越过守卫时间加一。
              temp.time++;
              vis[temp.x][temp.y]=1;
              Q.push(temp);
          }
      }
  }
  return -1;
}
int main()
{
 int i,j,k;
 int fx,fy;
  while(cin>>n>>m)
  {
      for(i=0;i<n;i++)
      for(j=0;j<m;j++)
      {
        cin>>map[i][j];
        if(map[i][j]=='r')
            fx=i,fy=j;
      }
      i=DFS(fx,fy,0);
      if(i>=0)
      printf("%d\n",i);
      else  
      printf("Poor ANGEL has to stay in the prison all his life.\n");  
    }
 return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值