A Knight's Journey

A Knight's Journey

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 29239
Accepted: 10025

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4



#include <iostream>
#include <algorithm>
using namespace std;
int n,k,tot,cur,z;
#define M 35
int vis[M][M],v[2][M];            //vis[][]是用来判断这点能不能走,v[][]是记录横纵坐标,因为要输出顺序。
char mat[2][M];                   //mat[][]就是记录坐标代表的字符,字母和数字分开。
int dir[8][2]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2}; //字典序,这样是题目的规定。
void dfs (int x,int y,int cur)
{   
    int i,j;
    if(cur==k*z&&tot==0)
    { printf("A1");            //因为起点是人为定的,所以单独输出。
      tot++;
      for(i=1;i<k*z;i++)
      {
           printf("%c%c",mat[0][v[1][i]]+16,mat[1][v[0][i]]);  
           //字符数字变字母+16,其实mat[0][]=mat[1][].
      }
      printf("\n\n");

    }
   else
   {   for(int K=0;K<8;K++)
      {
          int a=x+dir[K][0];
          int b=y+dir[K][1];
          if(vis[a][b]==1)
          {   
              v[0][cur]=a;v[1][cur]=b;
              vis[a][b]=0;
              dfs(a,b,cur+1);
              vis[a][b]=1;
          }
   }
}
}
int main()  
{  
    int i,j,d;
    for(i=2;i<=M-2;i++)
    {
        mat[0][i]=mat[1][i]=i+47;
    }
   while(scanf("%d",&n)!=EOF)  
    {  
        for(d=1;d<=n;d++)
        {   
            scanf("%d%d",&k,&z); 
            printf("Scenario #%d:\n",d);
            memset(vis,0,sizeof(vis));
            tot=0;
            for(i=2;i<k+2;i++)
                for(j=2;j<z+2;j++)
                      vis[i][j]=1;
                vis[2][2]=0;
                dfs(2,2,1); 
                if(tot==0)
                    printf("impossible\n\n");
        }   
   } 
    return 0;  
} 
  代码极其简陋,我完全是按照代码模板打的,所以东西都是东拼西凑来的。
200+MS才过,还是有人指点,字母是从数字加上来的。
 我是建了两层围墙,因为马能跳两格,这样我就不用去考虑边界问题,
总是在这些地方出现小问题,如果到了边界就要判断X>0&&X<k&&Y>0&&Y<Z也可以。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值