1017 Problem Q

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …<br>The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?<br><center><img src=../../../data/images/C154-1003-1.jpg> </center><br>
 

Input
The first line contain a integer T , the number of cases.<br>Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2<sup>31</sup>).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14


思路:动态规划问题  之前一直是compile error,在codeblocks上是没有问题的,后来才发现memset必须加String头文件。这题是一道背包题,如果只考虑第i件物品,则会有如果前i-1件物品放入了背包,第i件物品是否能放下,前i-1件物品获得的最大价值问题,然后又有了一种地推的意思...

源码:

#include <iostream>
#include <string.h>
using namespace std;

int main()
{
    int f[2000];
    int t,n,V,v[1000],w[1000],i,j;
    cin>>t;
    while(t--){
        cin>>n>>V;
        for(i=1;i<=n;i++)
        cin>>w[i];
        for(i=1;i<=n;i++)
        cin>>v[i];
        memset(f,0,sizeof(f));
        for(i=1;i<=n;i++)
        for(j=V;j>=v[i];j--)
        {
            if(f[j]>f[j-v[i]]+w[i])
            f[j]=f[i];
            else
            f[j]=f[j-v[i]]+w[i];
            }
        cout<<f[V]<<endl;
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值