Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
//kmp
#pragma warning(disable:4996)
#include"iostream"
#include"functional"
#include"algorithm"
#include"cstring"
#include"stack"
#include"cmath"
#include"queue"
#include"vector"
#include"map"
typedef long long int ll;
using namespace std;
const ll maxn=1e6+10;
ll nex[maxn],s[maxn],w[maxn],n,m;
void get_nex(){
ll j=-1,i=0;
//j是个数 坐标+1 nex数组 右移一位储存
nex[0]=-1;
while(i<m){
if(j==-1||s[j]==s[i]) nex[++i]=++j;
else j=nex[j];
}
}
ll kmp(){
ll j=0;
get_nex();
for(ll i=0;i<n;i++){
while(j&&w[i]!=s[j]) j=nex[j];
if(w[i]==s[j]) j++;
if(j==m) return i-m+2;
}
return -1;
}
int main(){
ll a;
cin>>a;
while(a--){
cin>>n>>m;
for(int i=0;i<n;i++) cin>>w[i];
for(int j=0;j<m;j++) cin>>s[j];
cout<<kmp()<<endl;
}
}