POJ-3069-Saruman's Army(Java简单贪心)

6 篇文章 0 订阅
Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4699 Accepted: 2430

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source




首先解释一下题目(博主英文渣!)(翻译出自《挑战程序设计竞赛》):直线上有N个点。点i的位置是Xi。从这N个点中选择若干个,给它们加上标记。对每一个点,其距离为R以内的区域里必须有带有标记的点(自己本身带有标记的点,可以认为与其距离为0的地方有一个带有标记的点)。在满足这个条件的情况下,希望能为尽可能少的点添加标记。请问至少要有多少点被加上标记?

限制条件:
1.  1<=N<=1000
2.  0<=R<=1000
3.  0<=Xi<=1000

样例:

输入:
R=10    N=6
X={1,7,15,20,30,50}

输出:
3


/*
 * 从最左边的点开始考虑,对于这个点,到距R以内的区域内必须要有带有标记的点。
 * 此点位于最左边,显然带有标记的点一定在此点右侧!所以从最左边的点开始,距离
 * 为R以内的最远的点,对于添加了符号的点右侧超过R的下一个点,可以把这个点看作
 * 第一次最左边的那个点,因为这两个点是等价的,即采用同样的方法即可!
 */

import java.io.*;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		while (input.hasNext())
		{
			int R = input.nextInt();
			int N = input.nextInt();
			int X[] = new int[N];
			for (int i = 0; i < N; i++)
			{
				X[i] = input.nextInt();
			}
			Arrays.sort(X);
			int i = 0, ans = 0;
			while (i < N)
			{
				int s = X[i++];
				// 一直向右前进直到距s的距离大于R的点
				while (i < N && X[i] <= s + R)
					i++;
				// p是新加上标记的点的位置
				int p = X[i - 1];
				// 一直向右前进直到距p的距离大于R的点
				while (i < N && X[i] <= p + R)
					i++;
				ans++;
			}
			System.out.println(ans);
		}
	}

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值