HDU 1163 Eddy's digital Roots

/*
题目大意:求每个位数上的数相加,直到之和小于10,对9取余就可以了
解题思路:中国同余定理
关键点:在乘以n的次方时,要一边乘一边对9求余
解题人:lingnichong
解题时间:2014/08/08      17:51
解题感受:中国同余定理的使用,在乘以n的次方时,要一边乘一边对9求余。是一个经典的例题
*/


Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4354    Accepted Submission(s): 2459


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
  
  
2 4 0
 

Sample Output
  
  
4 4
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1164  1194  1196  1170  1014 
 



#include<stdio.h>
int main()
{
	int n,a,i;
	while(scanf("%d",&n),n)
	{
		a=n;
		for(i=1;i<n;i++)
		{
			a=a*n%9;
		}
		if(a==0)
			printf("9\n");
		else
			printf("%d\n",a);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值