HDU 1196 Lowest Bit

156 篇文章 0 订阅
13 篇文章 0 订阅

/*
题目大意:将一个数变成一个二进制数,输出最小的一个数
解题思路:小的知识点,了解while循环即可,细心一点应该就可以了
难点详解:熟悉用while语句
关键点:输出后面的最后一个,最小的一个数
解题人:lingnichong
解题时间:2014-08-11 23:14:01
解题感受:水题吧,但也要想清楚
*/


Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7819    Accepted Submission(s): 5755


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 

Output
For each A in the input, output a line containing only its lowest bit.
 

Sample Input
  
  
26 88 0
 

Sample Output
  
  
2 8
 




#include<stdio.h>
int a[1000];
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		int k=0,j,t,s=0,m;
		while(n)
		{
			a[k++]=n%2;
			n/=2;
		}
		for(j=0;j<k;j++)
		{
			if(a[j]==1)
			{
				t=j;
				break;
			}
		}
		for(j=0,m=1;j<=t;j++,m*=2)
		{
			s=s+a[j]*m;
		}
		printf("%d\n",s);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值