HDU 1789 Doing Homework again【贪心】

156 篇文章 0 订阅
45 篇文章 0 订阅

/*
题目大意:

输入多组数据,第一行输入T,第二行输入一个正整数N,N表示有N门课程,之后的第一行输入N最后上交的日期,在后面一行输入对应科目迟交作业要扣掉的相应分数。
    输出总共扣的最少分数

解题思路:

    先对日期从小到大排序,如果日期相同,则扣分多的排在前面。如果相同日期内有扣分多的,则就用前面做扣分少的作业的时间来做这门作业;如果没有比他小的,就扣这门作业的分。

解题人:linnichong
解题时间:2014-10-29 02:02:46
解题体会:在对日期从小到大排序还知道怎么去做,但后面的用红字写的实在没想到。大哭
*/


Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)   
 Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

Author
lcy
 

Source
 

Recommend
lcy
 

#include<stdio.h>
#include<algorithm>
using namespace std;
struct work
{
	int cos;
	int time;
	bool flag;
}a[1005];

bool cmp(work a1,work a2)
{
	if(a1.time !=a2.time)
		return a1.time < a2.time;
	return a1.cos > a2.cos;
}

int main()
{
	int T,n,i,j,k;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i].time);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i].cos);
			a[i].flag = true; 
		}
		sort(a,a+n,cmp);
		int sum=0,k=1;
		for(i=0;i<n;i++)
		{
			if(a[i].time >= k)
			{
				k++;
				continue;
			}
			int p=a[i].cos,pas=i;
			for(j=0;j<i;j++)
				if(a[j].cos < p && a[j].flag)
				{
					p = a[j].cos;
					pas = j;
				}
			sum += p;
			a[pas].flag=false;
			
		}
		printf("%d\n",sum);
		
		
	}
	
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值