cigarettes
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
2
-
描述
-
Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them
one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?-
输入
- First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k. 输出
- For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have. 样例输入
-
3 4 3 10 3 100 5
样例输出
-
5 14 124
来源
- [rooot]原创
我模拟计算过程的,比较慢,暂时先这样写吧!现在想不出来其他的了。
#include<stdio.h>
int main()
{
int s,n,k,i,r,sum;
scanf("%d",&s);
while(s--)
{
sum=0;
scanf("%d%d",&n,&k);
r=n;
while(r>=k)
{
sum+=r/k;
r=r/k+r%k;
}
printf("%d\n",n+sum);
}
return 0;
}