POJ 3624 Charm Bracelet(0-1背包问题、动态规划)

重点哦,题目点我看。

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44890 Accepted: 19213

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source


解题思路:

如果用二维数组,提交上去肯定超内存,因为数组太大了。通过对数组的优化,改用一维数组(滚动数组),就能通过。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 3500
int F[13000];//使它们的总体积不超过j的最优取法取得的价值总和 
int w[MAXN],d[MAXN];
int main(){
	int N,M;
	scanf("%d %d",&N,&M);//N个物品,体积为 M的背包 
	memset(F,0,sizeof(F));//将数组F初始化 
	for(int i = 1; i <= N; i++)
		scanf("%d %d",&w[i],&d[i]);//体积 w[i]、价值 d[i]
	for(int j = 1; j <= M; j++){ //此处为边界条件。F数组初始化为取1个物品时,体积为j 的最大价值,此后不断更新
		if(w[1] <= j)
			F[j] = d[1];
		else
			F[j] = 0;
	}
	for(int i = 2; i <= N; i++)//从前i个物品取体积为j
		for(int j = M; j >= 1; j--){
		if(j - w[i] >= 0)//第i个物品可以取的话,尝试更新
			F[j] = max(F[j],F[j - w[i]] + d[i]);//取或不取第 i 种物品,两者选优(j-w[i]>=0才有第二项) 
	}	
	printf("%d\n",F[M]);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值