迷宫问题(bfs输出路径)

题目描述
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:
用pre结构体数组记录每个节点的父节点坐标

#include <bits/stdc++.h>
using namespace std;
int mp[5][5],vis[5][5];
int ne[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node{
    int x,y;
};
node pre[10][10];
void bfs(){
    queue<node> que;
    node str;
    str.x=str.y=0;
    que.push(str);
    vis[0][0]=1;
    while (!que.empty()){
        node now = que.front();
        que.pop();
        if (now.x == 4 && now.y == 4)
            return;
        for (int i = 0;i < 4;i++){
            node next;
            next.x = now.x + ne[i][0];
            next.y = now.y + ne[i][1];
            if(next.x >= 0 && next.x < 5 && next.y >= 0 && next.y < 5 && !mp[next.x][next.y] && !vis[next.x][next.y]){
                vis[next.x][next.y] = 1;
                que.push(next);
                pre[next.x][next.y] = now;
            }
        }
    }
}
void print(node cur){
    if (cur.x == 0 && cur.y == 0){
        printf("(0, 0)\n");
        return;
    }
    print(pre[cur.x][cur.y]);   //逆序输出
    printf("(%d, %d)\n",cur.x,cur.y);
}
int main(){
    for(int i = 0;i < 5;i++){
        for(int j = 0;j < 5;j++){
        	scanf("%d",&mp[i][j]);	
        }    	
    }       
    bfs();
    node ed;
    ed.x = ed.y = 4;
    print(ed);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值