一、题目描述
2075: 迷宫问题
Time Limit: 1 Sec Memory Limit: 512 MB
Submit: 397 Solved: 175
[Submit] [Status] [Web Board] [Creator:Imported]
Description
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。最短路径保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input Copy
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output Copy
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
二、题目思路
题目求最短路径,首先想到bfs做法,因为bfs每次扩散出来的节点,如果满足,那必是最短路径,然后有个子问题就是怎么输出路径,节点中添加一个pre,连接上一个父节点,这样我们就可以递归输出啦!
三、题解代码
下面展示一些 内联代码片
。
#include<iostream>
using namespace std;
int first, zz; //父节点 子节点
int mapp[5][5]; //开图
int movex[4] = { 1,-1,0,0 };
int movey[4] = { 0,0,1,-1 };
//构造节点
struct node
{
int x, y, pre; //横纵坐标,pre连接上一个节点,用于输出
}node[100];
//判断节点是否合法
bool is_go(int x, int y)
{
if (x < 0 || x>4 || y < 0 || y>4||mapp[x][y])
return false;
else
return true;
}
void output(int i)
{
if (node[i].pre != -1)
{
output(node[i].pre);//递归输出
cout << "(" << node[i].x << ", " << node[i].y << ")" << endl;
}
}
void bfs(int x, int y)
{
node[first].x = x;
node[first].y = y;
node[first].pre = -1;
while (first < zz)
{
for (int i = 0; i < 4; i++)
{
int xx = movex[i] + node[first].x;
int yy = movey[i] + node[first].y;
if (xx == 4 && yy == 4)
{
output(first);
}
if (!is_go(xx, yy))
{
continue;
}
else
{
mapp[xx][yy] = 1;
node[zz].x = xx;
node[zz].y = yy;
node[zz].pre = first;
zz++;
}
}
first++;
}
}
int main()
{
for(int i = 0;i<5;i++)
{
for (int j = 0; j < 5; j++)
{
cin >> mapp[i][j];
}
}
first = 0, zz = 1;
cout <<"(0, 0)"<< endl;
bfs(0,0);
cout << "(4, 4)";
return 0;
}
不足之处请斧正。