【PAT题解】Shopping in Mars

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯D**N (D**i≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of ij such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of ij such that Di + … + Dj >M with (Di + … + DjM) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

分析

将所有子序列的和,构成一个矩阵

例:

5 13
2 4 5 7 9

image-20210325164047650

矩阵中的数据是有一定的规律的,既从左到右,从下到上递增,可以按照这些数据的规律,寻找答案

由于数据最大有100000个,使用二维矩阵是很不理想的,或许上三角矩阵可以,当然可以模拟这个过程

代码实现

#include <cstdio>
#include <vector>
using namespace std;
vector<int> res, sum;
int main() {
    int n, m,temp;
    int k = 1;              // 最接近目标的 1-k 序列
    int min = 99999999;     // 最接近目标的最小序列和
    scanf("%d %d", &n, &m);
    sum.resize(n + 1);
    for (int i = 1; i <= n; ++i) {
        scanf("%d", &temp);
        sum[i] = sum[i - 1] + temp; // 保存 1-i 的序列和
        if (sum[i]<m){              // 寻找最接近目标的序列和
            k=i;
        }
    }
    /* sum[k]有两种情况,一种是小于目标值,一种是刚好等于目标值*/
    if (sum[k] < m) {
        k++;        // 小于的时候,不满足题目要求,需要一个比目标值大的数
    }
    /* 1-k 的序列和最接近目标值*/
    temp = min=sum[k];
    int i = 1, j = k;
    while (i <= n && j <= n) {
        if (temp < m) {     // 小于目标值,往右搜索
            temp = sum[++j] - sum[i - 1];
            continue;
        }
       /*有更合适的选择或者相同的选择*/
        if (temp <= min) {
            if (temp < min) {   // 有更合适的序列 更新
                min = temp;
                res.clear();
            }
            /*加入到结果集*/
            res.push_back(i);
            res.push_back(j);
        }
        temp = sum[j] - sum[i++];   // 下移
    }
    for (int t = 0; t < res.size(); t += 2) {
        printf("%d-%d\n", res[t], res[t + 1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值