POJ - 1338 Ugly Numbers-STL的灵活运用

POJ - 1338
Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n'th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10
map拥有自动排序的强大功能
/*
Author: 2486
Memory: 680 KB		Time: 16 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <map>
#include <iterator>
using namespace std;
typedef long long LL;
const int maxn=1500+5;
int S[]= {2,3,5};
LL dp[maxn];
priority_queue<LL,vector<LL>, greater<LL> >G;
map<LL,int>P;
int n;
void pri() {
    G.push(1);
    P[1]=1;
    int cnt=0;
    while(true) {
        LL a=G.top();
        G.pop();
        cnt++;
        if(cnt>1500+4)break;
        for(int i=0; i<3; i++) {
            LL b=a*S[i];
            if(!P[b]) {
                P[b]=1;
                G.push(b);
            }
        }
    }
    map<LL,int>::iterator it;
    cnt=1;
    for(it=P.begin(); it!=P.end(); it++) {
        dp[cnt++]=it->first;
        if(cnt>1500)return;
    }
}
int main() {
    pri();
    while(~scanf("%d",&n),n) {
        printf("%I64d\n",dp[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值