POJ - 1463Strategic game入门树形DP

POJ - 1463
Time Limit: 2000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u

 Status

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or 
    node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2
   
   
题目描述了一个树形结构,在结点上可安放0个或1个士兵,要求在满足每条边的两端至少有一个士兵的条件下求得士兵最少数度优先搜索遍历树的每一个节点,对于一个节点x,存在两种状态dp[x][0],dp[x][1],以1表示放置,0表示不放置,dp[x][1]表示节点x放置士兵情况下以x为节点子树的最优值,同理d[x][0]表示不放置为最优值.
转移方程为: d[x][1] += min(d[to][0], d[to][1]),如果此处放东西,那么下一个有两个选择,一个是放置一个是不放置 d[x][0] += d[to][1]//如果此处不放东西,那么他的子节点必定是放置士兵的,不然x与to之间就会没有士兵的存在,不符合题意。
最后结果为根节点放置和不放置情况中的最优值
/*
Author: 2486
Memory: 712 KB		Time: 375 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn = 1500 + 5;
vector<int> Edge[maxn];
int n, dp[maxn][2];
bool vis[maxn];
void DFS(int x) {
    vis[x] = true;
    dp[x][1] = 1;
    dp[x][0] = 0;
    for(int i = 0; i < Edge[x].size(); i ++) {
        int to=Edge[x][i];
        if(vis[to]) continue;
        DFS(to);
        dp[x][1] += min(dp[to][1], dp[to][0]);
        dp[x][0] += dp[to][1];
    }
}
int main() {
    int x, y, z;
    while(~ scanf("%d", &n)) {
        memset(vis, false, sizeof(vis));
        for(int i = 0; i < n; i ++) {
            Edge[i].clear();
        }
        for(int i = 0; i < n; i ++) {
            scanf("%d:(%d)", &x, &y);
            while(y --) {
                scanf("%d", &z);
                Edge[x].push_back(z);
                Edge[z].push_back(x);
            }
        }
        DFS(0);//这里以为根节点
        printf("%d\n", min(dp[0][1], dp[0][0]));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值