HDU - 5012 Dice

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

 Status

Description

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a   1.a   2,a   3,a   4,a   5,a   6  to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b   1.b   2,b   3,b   4,b   5,b   6  to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a   i  ≠ a   j  and b   i  ≠ b   j  for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.  

At the beginning, the two dices may face different(which means there exist some i, a   i  ≠ b   i). Ddy wants to make the two dices look the same from all directions(which means for all i, a   i  = b   i) only by the following four rotation operations.(Please read the picture for more information)  


Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.  
 

Input

There are multiple test cases. Please process till EOF.  

For each case, the first line consists of six integers a   1,a   2,a   3,a   4,a   5,a   6, representing the numbers on dice A.  

The second line consists of six integers b   1,b   2,b   3,b   4,b   5,b   6, representing the numbers on dice B.
 

Output

For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input

    
    
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output

    
    
0 3 -1
 

#include<iostream>
#include<queue>
#include<string>
#include<cstdlib>
#include<cstdio>
using namespace std;         //bfs,很水很水的题
int a[7];
int b[7];
int v[7][7][7][7][7][7];
struct node
{
	int d[7];
	int ans;
};
struct node s, t;
int bfs()
{
	queue<node>q;
	for (int i = 1; i <= 6; i++)
		t.d[i] = a[i];
	t.ans = 0;
	q.push(t);
	v[t.d[1]][t.d[2]][t.d[3]][t.d[4]][t.d[5]][t.d[6]] = 1;
	while (!q.empty())
	{
		t = q.front();
		q.pop();
		if (t.d[1] == b[1] && t.d[2] == b[2] && t.d[3] == b[3] && t.d[4] == b[4] && t.d[5] == b[5] && t.d[6] == b[6])
		{
			printf("%d\n", t.ans);
			return 1;
		}
		for (int i = 1; i <= 4; i++)
		{
			if (i == 1)
			{
				s.d[1] = t.d[4];
				s.d[2] = t.d[3];
				s.d[3] = t.d[1];
				s.d[4] = t.d[2];
				s.d[5] = t.d[5];
				s.d[6] = t.d[6];
				if (v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] == 0)
				{
					s.ans = t.ans + 1;
					v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] = 1;
					q.push(s);
				}
			}
			else if (i == 2)
			{
				s.d[1] = t.d[3];
				s.d[2] = t.d[4];
				s.d[3] = t.d[2];
				s.d[4] = t.d[1];
				s.d[5] = t.d[5];
				s.d[6] = t.d[6];
				if (v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] == 0)
				{
					s.ans = t.ans + 1;
					v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] = 1;
					q.push(s);
				}
			}
			else if (i == 3)
			{
				s.d[1] = t.d[6];
				s.d[2] = t.d[5];
				s.d[3] = t.d[3];
				s.d[4] = t.d[4];
				s.d[5] = t.d[1];
				s.d[6] = t.d[2];
				if (v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] == 0)
				{
					s.ans = t.ans + 1;
					v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] = 1;
					q.push(s);
				}
			}
			else if (i == 4)
			{
				s.d[1] = t.d[5];
				s.d[2] = t.d[6];
				s.d[3] = t.d[3];
				s.d[4] = t.d[4];
				s.d[5] = t.d[2];
				s.d[6] = t.d[1];
				if (v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] == 0)
				{
					s.ans = t.ans + 1;
					v[s.d[1]][s.d[2]][s.d[3]][s.d[4]][s.d[5]][s.d[6]] = 1;
					q.push(s);
				}
			}
		}
	}
	return 0;
}

int main()
{
	int F;
	while (scanf("%d%d%d%d%d%d", &a[1], &a[2], &a[3], &a[4], &a[5], &a[6])!=EOF) //加EOF啊笨蛋,在这TE这么多次太对不起学的算法了
	{   
		for (int i = 1; i <= 6; i++)
			scanf("%d", &b[i]);
		memset(v, 0, sizeof(v));
		F = bfs();
		if (F==0) printf("-1\n");
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

这波lucio来全学了

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值