UVA_10815: Andy's First Dictionary

Input
The input file is a text with no more than 5000 lines.  An input line has at most 200 characters.  Input is terminated by EOF.

Output
Your output should give a list of different words that appears in the input text,  one in a line.  The words should all be in lower case,  sorted in alphabetical order.  You can be sure that he number of distinct words in the text does not exceed 5000.

SampleInput

Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."
So they went home.

SampleOutput

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were

when


分析:本题主要考察STL的应用,利用set和string可以很快的完成


#include <iostream>
#include <string>
#include <set>
#include <sstream>

using namespace std;

set<string> dict;

int main()
{
	string s, buf;
	while(cin >> s)
	{
		for(int i=0; i<s.length(); i++)
			if(isalpha(s[i]))s[i]=tolower(s[i]);
			else s[i]=' ';
		stringstream ss(s);
		while(ss >> buf) dict.insert(buf);
	}

	for(set<string>::iterator it = dict.begin(); it!=dict.end(); it++)
		cout << *it << "\n";
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值