hdu 1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 142238    Accepted Submission(s): 34578


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5

代码:

#include<iostream>
#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
using namespace std;
int f(int a,int b,long long n)
{
    a%=7;
    b%=7;
    if(n>=49)
        n%=49;
    if(n==2||n==1)
        return 1;
    return (a*f(a,b,n-1)+b*f(a,b,n-2))%7;
}
int main()
{
    int a,b;
    long long n;
    while(cin>>a>>b>>n&&!(a==0&&b==0&&n==0))
    {
        cout<<f(a,b,n)<<endl;
    }
    return 0;
}


注:

因为模总是在0~6之间,所以f(i-1)与f(i-2)也是如此,所以公式就有7X7=49种情况,49以后肯定是一个循环

(有的是用矩阵快速幂做,

矩阵快速幂 学习笔记 - AC_Von - 博客园
http://www.cnblogs.com/vongang/archive/2012/04/01/2429015.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值