HDU 5172 pairs

HDU 5172 pairs


Problem Description
John has n points on the X axis, and their coordinates are (x[i],0),(i=0,1,2,…,n−1). He wants to know how many pairs<a,b> that |x[b]−x[a]|≤k.(a<b)


Input
The first line contains a single integer T (about 5), indicating the number of cases.
Each test case begins with two integers n,k(1≤n≤100000,1≤k≤109).
Next n lines contain an integer x[i] (−109≤x[i]≤109), means the X coordinates.


Output
For each case, output an integer means how many pairs<a,b> that |x[b]−x[a]|≤k.


Sample Input
2
5 5
-100
0
100
101
102
5 300
-100
0
100
101
102


Sample Output
3
10


题意:判断有多少数满足|x[b]−x[a]|≤k.(a<b)

注意:(1≤n≤100000,1≤k≤109).数据过多,暴力计算会TLE

首先对数组按升序排序
 用一个数组pos[i]记录x[i]右边最远的x[b]的b值,由于x[b]是单调递增的,所以找pos[i+1]时只要将b从pos[i]继续往右找即可。

另外答案结果非常大,应用long long来保存


#include<cstdio>
#include <iostream>
#include<algorithm>
#include <string.h>
#define N 100200
using namespace std;
long a[N], p[N];

int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif
    int T;
    long n, k, i, j;
    long long ans;
    cin >> T;
    while(T--)
    {
        ans = 0;
        memset(p, 0, sizeof(p));
        cin >> n >> k;
        for (i = 0; i < n; i++)
        {
            cin >> a[i];
        }
        sort(a, a+n);
        for(i = 0; i < n; i++)
        {
            if (i)
            {
                for(j = p[i - 1]; j <= n; j++)
                {
                    if ((j < n && a[j] > a[i] + k) || (j == n))
                    {
                        p[i] = j - 1;
                        ans += j - i - 1;
                        break;
                    }
                }
            }
            else
            {
                for (j = i + 1; j <= n; j++)
                {
                    if ((j < n && a[j] > a[i] + k) || (j == n))
                    {
                        p[i] = j - 1;
                        ans += j - i - 1;
                        break;
                    }
                }
            }
        }
        cout << ans << endl;
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值