Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
Sample Input
1 2 3
Sample Output
1 2 4
思路如下:
一个长度n的队列可以看成一个n - 1的队列再追加的1个小孩,这个小孩只可能是:
a.男孩,任何n - 1的合法队列追加1个男孩必然是合法的,情况数为f[n - 1];
b.女孩,在前n - 1的以女孩为末尾的队列后追加1位女孩也是合法的,我们可以转化为n - 2的队列中追加2位女孩;
一种情况是在n - 2的合法队列中追加2位女孩,情况数为f[n - 2];
但我们注意到本题的难点,可能前n - 2位以女孩为末尾的不合法队列(即单纯以1位女孩结尾),也可以追加2位女孩成为合法队列,而这种n - 2不合法队列必然是由n - 4合法队列+1男孩+1女孩的结构,即情况数为f[n - 4]。
得出递推公式如下:
f[n] = f[n - 1] + f[n - 2] + f[n - 4]
还有需要注意的是本题中可能得出极大的数字,如当n为1000时,结果为:
12748494904808148294446671041721884239818005733501580815621713101333980596197474744336199742452912998225235910891798221541303838395943300189729514282623665199754795574309980870253213466656184865681666106508878970120168283707307150239748782319037
这种超大数完全不是C++提供的数值类型能够储存的,因此我们可以使用数组来模拟超大数运算
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const long long M = 100000+10, N = 1e9+7;
long long int n, f[1111][111];
int main()
{
#ifndef ONLINE_JUDGE
//freopen("1.txt", "r", stdin);
#endif
int i, j;
memset(f, 0, sizeof(f));
f[0][1] = 1;
f[1][1] = 1;
f[2][1] = 2;
f[3][1] = 4;
f[4][1] = 7;
for (i = 5; i <= 1000; i++)
{
for (j = 1; j < 100; j++)
{
f[i][j] += f[i - 1][j] + f[i - 2][j] + f[i - 4][j];
f[i][j+1] += f[i][j]/10000;
f[i][j] %= 10000;
}
}
while(~scanf("%d", &n))
{
i = 99;
while(!f[n][i--]);
cout << f[n][i+1];
for (; i > 0; i--)
printf("%04d", f[n][i]);
cout << endl;
}
return 0;
}