UVA514-Rails

UVA514-Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station
was built in last century. Unfortunately, funds were extremely limited that time. It was possible to
establish only a surface track. Moreover, it turned out that the station could be only a dead-end one
(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the direction
B with coaches reorganized in some way. Assume that the train arriving from the direction A has
N ≤ 1000 coaches numbered in increasing order 1, 2, . . . , N. The chief for train reorganizations must
know whether it is possible to marshal coaches continuing in the direction B so that their order will
be a1.a2, . . . , aN . Help him and write a program that decides whether it is possible to get the required
order of coaches. You can assume that single coaches can be disconnected from the train before they
enter the station and that they can move themselves until they are on the track in the direction B. You
can also suppose that at any time there can be located as many coaches as necessary in the station.
But once a coach has entered the station it cannot return to the track in the direction A and also once
it has left the station in the direction B it cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly
more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of 1, 2, . . . , N. The last line of the
block contains just ‘0’.
The last block consists of just one line containing ‘0’.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line
of the output file contains ‘Yes’ if it is possible to marshal the coaches in the order required on the
corresponding line of the input file. Otherwise it contains ‘No’. In addition, there is one empty line after
the lines corresponding to one block of the input file. There is no line in the output file corresponding
to the last “null” block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No
Yes

思路:

考察栈,直接模拟火车进站、出栈,将题目中的station看成栈,将1,2,……n依次入栈,每次入栈后判断栈顶元素和给定序列的元素是否相同,若相同则出栈,直至出现不同。全部入栈操作完之后,若栈中还有元素则给定的出栈顺序是不可行的,若没有就是可行的。

代码:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main() {
	
	while(1){
		int n;	//车厢节数
		scanf("%d",&n);
		if(n==0) break;
		int ord[1010];
		
		while(1){
			scanf("%d",&ord[0]);
			if(ord[0]==0) break;
			
			for(int i=1;i<n;i++){
				scanf("%d",&ord[i]);	
			}
			
			//zhan
			stack<int> sta;
			int p=0;
			
			for(int i=1;i<=n;i++){
				while(!sta.empty()){
					if(sta.top()==ord[p]){
						sta.pop();
						p++;	
					}
					else{
						break;
					}
				
				}
					
				sta.push(i);
			} 
			
			
			while(p<n){
				if(sta.top()==ord[p]){
					sta.pop();
					p++;	
				}
				else{
					break;
				}
				
			}
			
			if(sta.empty()) cout<<"Yes"<<endl;
			else cout<<"No"<<endl;
		} 
		printf("\n");
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

u小鬼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值