hdu 1528 Card Game Cheater(二分图的最大匹配)

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1362    Accepted Submission(s): 723


Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

 

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 

Sample Input
  
  
3 1 JD JH 2 5D TC 4C 5H 3 2H 3H 4H 2D 3D 4D
 

Sample Output
  
  
1 1 2
 

Source
题目分析:
对第一个人,枚举每个点,向比它大的第二个人的牌建边,然后二分图求最大匹配即可
 
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cctype>
#define MAX 31

using namespace std;

int t,n;
char num[3][MAX];
char type[3][MAX];
char s[10];

struct Edge
{
    int v,next;
}e[MAX*MAX];

int head[MAX];
int cc;

void add ( int u , int v )
{
    e[cc].v = v;
    e[cc].next = head[u];
    head[u] = cc++;
}

bool cmp1 ( char ch1 , char ch2 )
{
    if ( ch1 == 'C' ) return true;
    if ( ch2 == 'H' ) return true;
    if ( ch1 == 'D' ) return ch2 == 'S' || ch2 == 'H';
    if ( ch1 == 'S' ) return ch2 == 'H';
    if ( ch1 == 'H' ) return false;
}

int cmp2 ( char ch1 , char ch2 )
{
    if ( isdigit (ch1 ) || isdigit(ch2 ) )
        return ch1 - ch2;
    if ( ch1 == 'T' )
        return ch2 == 'T'?0:-1;
    if ( ch1 == 'J' )
    {
        if ( ch2 == 'T' ) return 1;
        if ( ch2 == 'J' ) return 0;
        return -1;
    }
    if ( ch1 == 'Q' )
    {
        if ( ch2 == 'T' || ch2 == 'J' ) return 1;
        if ( ch2 == 'Q' ) return 0;
        return -1;
    }
    if ( ch1 == 'K' )
    {
        if ( ch2 == 'A' ) return -1;
        if ( ch2 == 'K' ) return 0;
        return 1;
    }
    if ( ch1 == 'A' )
    {
        if ( ch2 == 'A' ) return 0;
        return 1;
    }
}

int used[MAX];
int linker[MAX];

bool dfs ( int u )
{
    for ( int i = head[u] ; ~i ; i = e[i].next )
    {
        int v = e[i].v;
        if ( used[v] ) continue;
        used[v] = 1;
        if ( linker[v] == -1 || dfs ( linker[v] ) )
        {
            linker[v] = u;
            return true;
        } 
    }
    return false;
}

int hungary ( )
{
    int res = 0;
    memset ( linker , -1 , sizeof ( linker ) );
    for ( int i = 1 ; i <= n ; i++ )
    {
        memset ( used , 0 , sizeof ( used ) );
        if ( dfs ( i ) ) res++;
    }
    return res;
}

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        memset ( head , -1 , sizeof ( head ) );
        cc = 0;
        scanf ( "%d" , &n );
        for ( int i = 0 ; i < 2 ; i++ )
            for ( int j = 1 ; j <= n ; j++ )
            {
                scanf ( "%s" , s );
                num[i][j] = s[0];
                type[i][j] = s[1];
            }
        for ( int i = 1 ; i <= n ; i++ )
            for ( int j = 1 ; j <= n ; j++ )
            {
                int flag = cmp2 ( num[0][i] , num[1][j] );
                if ( !flag )
                {
                    if ( cmp1 ( type[0][i] , type[1][j] ) )
                       add ( i , j );
                }
                if ( flag < 0 )
                    add ( i , j ); 
            }
        printf ( "%d\n" , hungary ( ) );
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值