POJ 2062 Card Game Cheater

5 篇文章 0 订阅

Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, … , k}):
If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.
If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.
A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.
If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.
This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.
Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.
Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line
TC 2H JD

Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D

Sample Output
1
1
2

题意:
Adam和Eve玩牌,谁的牌大就得一分,已知Adam的出牌次序,问Eve最多能得几分
思路:
建立一个Card结构体,储存牌的面值(value)和花色(suit),重载运算符’<’,将两人的牌从大到小分别存入两个优先队列中。

#include <iostream>
#include<queue>
using namespace std;
int n;
struct Card
{
    char value;
    char suit;
    int transValue()//将字符转成整数
    {
        switch(value)
        {
            case'T':
                return 10;
            case'J':
                return 11;
            case'Q':
                return 12;
            case'K':
                return 13;
            case'A':
                return 14;
            default:
                return value-'0';
        }
    }
    int transSuit()
    {
        switch(suit)//将花色大小转化为整数表示
        {
            case 'C':return 1;
            case 'D':return 2;
            case 'S':return 3;
            case 'H':return 4;
            default:return 0;
        }
    }
    friend bool operator <(Card c1,Card c2)//重载运算符'<',利用优先队列自动排序并比较两人牌的大小
    {
        if(c1.transValue()!=c2.transValue())
        {
            return c1.transValue()<c2.transValue();
        }
        else
            return c1.transSuit()<c2.transSuit();
    }
};
priority_queue<Card> AdamsCard;
priority_queue<Card> EvesCard;
void read()//读入数据,将两人的牌存入队列,此时队列中牌按从大到小的顺序排好
{
    Card c;
    for(int i=0;i<n;i++)
    {
        cin>>c.value>>c.suit;
        AdamsCard.push(c);
    }
    for(int i=0;i<n;i++)
    {
        cin>>c.value>>c.suit;
        EvesCard.push(c);
    }

}
void countPoint()
{
    int point=0;
    Card c1,c2;
    while(!AdamsCard.empty())
    {
        c1=AdamsCard.top();//取出第一张牌,即此时Adam手中最大的牌
        c2=EvesCard.top();//取出此时Eve手中最大的牌
        if(c1<c2)//运算符重载,进行比较
        {
            point++;
            AdamsCard.pop();
            EvesCard.pop();
        }
        else
            AdamsCard.pop();
    }
    cout<< point<<endl;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        while(!AdamsCard.empty())//清空队列,注意没有clear函数
            AdamsCard.pop();
        while(!EvesCard.empty())
            EvesCard.pop();
        cin>>n;
        read();
        countPoint();
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值