LightOJ 1421 Wavio Sequence 最大上升子序列变形 双dp

Wavio Sequence

Description

Wavio is a sequence of integers. It has some interesting properties:

1.      Wavio is of odd length i.e. L = 2*n + 1.

2.      The first (n+1) integers of Wavio sequence make a strictly increasing sequence.

3.      The last (n+1) integers of Wavio sequence make a strictly decreasing sequence.

4.      No two adjacent integers are same in a Wavio sequence.

For example 1, 2, 3, 4, 5, 4, 3, 2, 1 is an Wavio sequence of length 9. But 1, 2, 3, 4, 5, 4, 3, 2, 2 is not a valid wavio sequence. In this problem, you will be given a sequence of integers. You have to find the length of the longest Wavio sequence which is a subsequence of the given sequence. Consider the given sequence as:

1 2 3 2 1 2 3 4 3 2 1 5 4 1 2 3 2 2 1

Here the longest Wavio sequence is: 1 2 3 4 5 4 3 2 1. So, the output will be 9.

Input

Input starts with an integer T (≤ 12), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 105) denoting the number of elements in the sequence. The next line contains N space separated integers between -108 to 108, that form the sequence.

Output

For each case, print the case number and the length of the maximum possible Wavio sequence.

Sample Input

3

10

1 2 3 4 5 4 3 2 1 10

14

1 2 3 2 1 2 3 4 3 2 1 5 4 1

5

1 2 3 4 5

Sample Output

Case 1: 9

Case 2: 7

Case 3: 1

    题意:按照题意求出一个对称的上升子序列的最大长度。

    分析:该题思路很容易想到,对于序列正序进行一遍最大上升子序列处理,再逆序求一次最大上升子序列。正序逆序两者中较小的就是以该点为中点可实现的序列的单边长度,最终所求长度*2-1即可。详细注释见AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn=100005;
const int INF=0x3f3f3f3f;
int a[maxn],b[maxn],dpa[maxn],dpb[maxn],ma[maxn],mb[maxn];
int main()
{
	//dpa 数组  i下标表示 以ai为尾数的上升子序列的最大长度
	//ma i下标表示  长度为i的上升子序列的尾数最小值
	int T,k=0;
	scanf("%d",&T);
	while(T--)
	{
		k++;
		int n;
		scanf("%d",&n);
		for(int i=0; i<n; i++)
		{
			scanf("%d",&a[i]);
			b[n-1-i]=a[i];// 逆序保存在b数组中
		}
		ma[0]=-1e8;
		ma[1]=a[0];//初始化
		dpa[0]=1;//dpa i 指的是i下标为尾数的子序列的长度
		int maxlen=1;//定义最大长度
		for(int i=1; i<n; i++)
		{
			int l=0,r=maxlen,mid;
			if(ma[maxlen]<a[i])//若不存在数比它大则加一位
			{
				ma[++maxlen]=a[i];
				dpa[i]=maxlen;//将以a[i]为尾数的子序列的最大长度更新
			}
			else
			{
				r=maxlen;
				while(l<=r)
				{
					mid=(l+r)/2;
					if(ma[mid]<a[i])
						l=mid+1;
					else
						r=mid-1;
				}//找出第一个大于a[i]的ma数组的下标
				ma[l]=a[i];//更新
				dpa[i]=l;// 更新该数的最大长度
			}
		}
		//对逆序数组重新求一遍 得到反向的lis
		mb[0]=-1e8;
		mb[1]=b[0];
		dpb[0]=1;
		maxlen=1;
		for(int i=1; i<n; i++)
		{
			int l=0,r=maxlen,mid;
			if(mb[maxlen]<b[i])
			{
				mb[++maxlen]=b[i];
				dpb[i]=maxlen;
			}
			else
			{
				r=maxlen;
				while(l<=r)
				{
					mid=(l+r)/2;
					if(mb[mid]<b[i])
						l=mid+1;
					else
						r=mid-1;
				}
				mb[l]=b[i];
				dpb[i]=l;
			}
		}
		int res=0;
		for(int i=0; i<n; i++)//较小者为其有效值  所求长度还需*2-1
			res=max(res,2*(min(dpa[i],dpb[n-i-1]))-1);
		printf("Case %d: %d\n",k,res);
	}
}
    算法基础很是欠缺,唯有多学算法多刷题,戒骄戒躁。

    特记下,以备后日回顾。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值