Minesweeper  UVA - 10189 JAVA

92 篇文章 0 订阅
75 篇文章 0 订阅

G - Minesweeper

 UVA - 10189 

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....

If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110

As you may have already noticed, each square may have at most 8 adjacent squares.

Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

Output

For each field, you must print the following message in a line alone:

Field #x:

Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

35'  模拟

扩展dir数组即可,对每个*的八个方向做一次遍历

import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int field = 0;
		int n = sc.nextInt();
		int m = sc.nextInt();
		while(sc.hasNext()) {
			field++;
			sc.nextLine();
			char[][] c = new char[n][m];
			String s = null;
			for (int i = 0; i < n; i++) {
				s = sc.nextLine();
				c[i] = s.toCharArray();
			}
			int arr[][] = new int[n][m];
			int[][] dir = {{-1,0},{1,0},{0,1},{0,-1},{1,1},{-1,-1},{-1,1},{1,-1}};
			int xx = 0,yy = 0;
			for (int i = 0; i < c.length; i++) {
				for (int j = 0; j < c[i].length; j++) {
					if(c[i][j]=='*') {
						arr[i][j]=-10000;
						for (int k = 0; k < dir.length; k++) {
							xx = i+dir[k][0];
							yy = j+dir[k][1];
							if(xx>=0&&xx<n&&yy>=0&&yy<m) {
								arr[xx][yy]++;
							}
						}
					}
				}
			}
			System.out.printf("Field #%d:\n",field);
			for (int i = 0; i < arr.length; i++) {
				for (int j = 0; j < arr[i].length; j++) {
					if(arr[i][j]<0) System.out.print('*');
					else if(arr[i][j]==0) System.out.print('0');
					else System.out.print(arr[i][j]);
				}
				System.out.println();
			}
			n = sc.nextInt();
			m = sc.nextInt();
			if(n==0&&m==0) break;
			System.out.println();
		}
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值