Lake Counting  POJ - 2386 JAVA

92 篇文章 0 订阅
75 篇文章 0 订阅

I - Lake Counting

 POJ - 2386 

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

45' 并查集 方向dir扩展  搜索(应该也可以BFS)
二维并查集降维更好用
初始p[i]=i好用

对每个w只需要遍历一次

注意要考虑单独一个W的情况,也是一个池塘!

结果联系并查集输出即可

import java.util.Scanner;

public class Main{
	static int p[];
	static int find(int x) {
		if(p[x]==x) return x;
		return p[x] = find(p[x]);
	}
	static void link(int x,int y) {
		int xx = find(x);
		int yy = find(y);
		if(xx>yy)	p[xx] = yy;
		else 	p[yy] = xx;
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int m = sc.nextInt();
		sc.nextLine();
		char[][] c = new char[n][m];
		String s = null;
		for (int i = 0; i < n; i++) {
			s = sc.nextLine();
			c[i] = s.toCharArray();
		}
		p = new int[n*m+5];
		for (int i = 0; i < p.length; i++) {
			p[i] = i;
		}
		int[][] dir = {{-1,0},{1,0},{0,1},{0,-1},{1,1},{-1,-1},{-1,1},{1,-1}};
		boolean vis[][] = new boolean[n][m];
		int ans[] = new int[n*m+5];
		int res=0;
		
		for (int i = 0; i < c.length; i++) {
			for (int j = 0; j < c[i].length; j++) {
				if(c[i][j]=='W') {
					vis[i][j]=true;
					boolean arround = false;	//一个单独池塘的情况
					for (int k = 0; k < dir.length; k++) {
						int xx = i+dir[k][0];
						int yy = j+dir[k][1];
						if(xx>=0&&xx<n&&yy>=0&&yy<m&&c[xx][yy]=='W') {
							arround = true;
							if(!vis[xx][yy])
								link(i*m+j,xx*m+yy);
						}
					}
					if(!arround) res++;
				}
			}
		}
		
		for (int i = 0; i < p.length; i++) {
			ans[find(p[i])]++;
		}
		for (int i = 0; i < ans.length; i++) {
			if(ans[i]>1) res++;
		}
		System.out.println(res);
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值