POJ 3069 Saruman's Army(贪心)

Saruman's Army

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4


从最左边开始考虑,对于这个点,到其距离为R以内的区域内必须要有带标记的点,而带有标记的点一定是该点右侧距离为R以内最远的点。加上第一个标记点以后,剩下的部分按同样的方式处理

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 1005;

int x[maxn];

int main()
{
	int r,n,i,j,k;
	while(~scanf("%d %d",&r,&n) && r != -1 && n != -1){
		for(i = 0;i < n;i++)
			scanf("%d",&x[i]);
		sort(x,x + n);
		int ans = 0;
		j = 0;
		while(j < n){
			int s = x[j++];
			while(j < n && x[j] <= s + r){
				j++;
			}
			int p = x[j - 1];
			while(j < n && x[j] <= p + r)
				j++;
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值