UVaOJ 10935 Throwing cards away I

Throwing cards away I

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at thebottom. The following operation is performed aslong as there are at least two cards in the deck:Throw away the top card and movethe card that is now on the top of thedeck to the bottom of the deck.Your task is to find the sequence of discardedcards and the last, remaining card.

Input

Each line of input (except the last) contains anumber n ≤ 50. The last line contains ‘0’ andthis line should not be processed.

Output

For each number from the input produce twolines of output. The first line presents the sequenceof discarded cards, the second line reportsthe last remaining card. No line will haveleading or trailing spaces. See the sample for theexpected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

题目大意:给出一堆牌,当牌数大于等于2张时进行如下操作

(1)拿走牌顶的第一张牌

(2)将新的第一张牌放到牌底

输出每次拿出的牌以及最后剩下的那张牌。

解题思路:队列模拟,注意输出格式!

代码如下:

#include <cstdio>
#include <queue>
#include <algorithm>

using namespace std;

int main()
{
	queue<int> que;
	int n;
	while(scanf("%d",&n) != EOF && n){
		for(int i = 1;i <= n;i++){
			que.push(i);
		}
	
		printf("Discarded cards:");
		while(que.size() >= 2){
			if(que.size() > 2)
				printf(" %d,",que.front());
			else
				printf(" %d",que.front());
			que.pop();
			int temp = que.front();
			que.pop();
			que.push(temp);
		}
		printf("\n");
		printf("Remaining card:");
		printf(" %d\n",que.front());
		que.pop();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值