POJ 3372 Candy Distribution

Candy Distribution

Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3 
4

Sample Output

YES
NO
YES
题目大意:有N个小孩围成一圈,老师先发给第一个小孩一颗糖,然后跳过0个人,给2号小孩发一颗糖,接着跳过1个人,给4号小孩发糖,再跳过2个人,给7号小孩发糖……以此类推,问N个小孩能否每个人得到一颗糖。

解题思路:刚开始读错了题意,以为是跳过的人数是0,1,2的循环……后来发现题意理解错了,是跳过依次0,1,2,3……个人。这道题是有规律的,打表发现只要N == 2 ^ k,所有人都可以得到糖果,所以关键在于如何判断N是否等于2 ^ k。一种方法是判断N & (N - 1)是否为0,若为0,则N是2 ^ k,否则不是。原理如下:

设N = 16(10) = 10000(2),则N - 1 = 15 = 01111(2),N & (N - 1) = 0

代码如下:

#include <cstdio>

typedef long long ll;

int main()
{
	ll n; 
	while(scanf("%lld",&n) != EOF){
		printf("%s\n",n & (n - 1) ? "NO" : "YES");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值