HDOJ 1712 ACboy needs your help(分组背包)

ACboy needs your help




Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6
题目大意:一个人m天复习n门课程,课程i复习j天的收益为a[i][j],求分配这m天能获得的最大收益是多少。

解题思路:分组背包问题,将每一门课程看成一组,每一组有m天可以选择,将m看做背包容量。程序中三层循环的顺序保证了每一门课的复习天数只选择一次。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn = 105;

int a[maxn][maxn];
int dp[maxn];

int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m) != EOF && (n || m)){
        for(int i = 1;i <= n;i++){
            for(int j = 1;j <= m;j++){
                scanf("%d",&a[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));

        for(int i = 1;i <= n;i++){//从第一组到第n组
            for(int j = m;j >= 0;j--){//容量从m到0
                for(int k = 1;k <= j;k++){//组i中可供选择的物品
                    dp[j] = max(dp[j],dp[j - k] + a[i][k]);
                }
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值