HDOJ 1198 Farm Irrigation(并查集)

Farm Irrigation




Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
  
  
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
  
  
2 3
题目大意:有11块小的方形土地,每一块土地上都有不同形状的水管,不同土地之间的水管可能连通,也可能不连通(见图2)。现在要把这些小方土地拼成一大块土地,每块小土地的中心都可以有一个水源,求拼成一大块土地之后所需要的最小水源数。

解题思路:使用并查集,将互相连通的土地放在一个集合里,注意边界判断和坐标转换。

代码如下:

#include <algorithm>
#include <cctype>
#include <climits>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <vector>
#define EPS 1e-6
#define INF INT_MAX / 10
#define LL long long
#define MOD 100000000
#define PI acos(-1.0)

int dir[4][2] = {{0,-1},{-1,0},{0,1},{1,0}};
int farm[11][4] = {
    //left up right down
    1,1,0,0,
    0,1,1,0,
    1,0,0,1,
    0,0,1,1,
    0,1,0,1,
    1,0,1,0,
    1,1,1,0,
    1,1,0,1,
    1,0,1,1,
    0,1,1,1,
    1,1,1,1,
};
const int maxn = 55;
int par[maxn * maxn],rank[maxn * maxn];
int mapp[maxn][maxn];
char feild[maxn][maxn];
void init(int n)
{
    for(int i = 0;i < n;i++){
        par[i] = i;
        rank[i] = 0;
    }
}

int find(int x)
{
    return par[x] == x ? x : par[x] = find(par[x]);
}

void unite(int x,int y)
{
    x = find(x);
    y = find(y);
    if(x == y)
        return ;
    if(rank[x] < rank[y]){
        par[x] = y;
    }
    else{
        par[y] = x;
        if(rank[x] == rank[y])
            rank[x]++;
    }
}
int main()
{
    int n,m;
    char ch;
    while(~scanf("%d %d",&n,&m) && n >= 1 && m >= 1){
        for(int i = 0;i < n;i++){
            scanf("%s",feild[i]);
        }
        for(int i = 0;i < n;i++){
            for(int j = 0;j < m;j++){
                mapp[i][j] = feild[i][j] - 'A';
            }
        }
        init(n * m);
        for(int i = 0;i < n;i++){
            for(int j = 0;j < m;j++){
                for(int k = 0;k < 4;k++){
                    int nx = i + dir[k][0];
                    int ny = j + dir[k][1];
                    if(nx < 0 || nx >= n || ny < 0 || ny >= m)
                        continue;
                    if(k == 0)//left
                        if(farm[mapp[nx][ny]][2] && farm[mapp[i][j]][0])
                            unite(nx * m + ny,i * m + j);
                    if(k == 1)//up
                        if(farm[mapp[nx][ny]][3] && farm[mapp[i][j]][1])
                            unite(nx * m + ny,i * m + j);
                    if(k == 2)//right
                        if(farm[mapp[nx][ny]][0] && farm[mapp[i][j]][2])
                            unite(nx * m + ny,i * m + j);
                    if(k == 3)//down
                        if(farm[mapp[nx][ny]][1] && farm[mapp[i][j]][3])
                            unite(nx * m + ny,i * m + j);
                }
            }
        }
        int ans = 0;
        for(int i = 0;i < n * m;i++){
            if(par[i] == i)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值