HDOJ 3635 Dragon Balls(并查集)

Dragon Balls



Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
  
  
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
  
  
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
题目大意:有N个城市,每个城市里面都有一颗龙珠。有两种操作T和Q,说明如下

T     A  B 将A城市中所有的龙珠移动到B城市

Q    A      输出A城市龙珠当前所在的城市、A城市的龙珠当前所在城市拥有的龙珠数目和A城市的龙珠的移动次数。

解题思路:T指令比较好处理,直接合并A与B即可。而对于Q指令,打印A龙珠所在城市与所在城市龙珠的数目都比较好处理,难处理的是A龙珠转移次数。容易想到的是利用vector记录每个城市有哪些龙珠,然后移动时将每个龙珠的次数都加1。很明显,这样做会TLE。对于每个龙珠的移动次数,我们可以利用类似于延迟标记的做法。将当前需要移动的龙珠次数加1,等到路径压缩时,再将子节点的移动次数加到根节点上。

代码如下:

#include <cstdio>
#include <cstring>
const int maxn = 10005;
int par[maxn],num[maxn],time[maxn];
int n,q;
void init()
{
    for(int i = 1;i <= n;i++){
        par[i] = i;
        num[i] = 1;
        time[i] = 0;
    }
}

int find(int x)
{
    if(par[x] == x)
        return x;
    int p = par[x];
    par[x] = find(par[x]);
    time[x] += time[p];
    return par[x];
}

void unite(int x,int y)
{
    x = find(x);
    y = find(y);
    if(x == y)
        return ;
    par[x] = y;
    num[y] += num[x];
    time[x] = 1;
}

int main()
{
    int t,ncase = 0;
    scanf("%d",&t);
    char op[2];
    int x,y;
    while(t--){
        scanf("%d %d",&n,&q);
        init();
        printf("Case %d:\n",++ncase);
        while(q--){
            scanf("%s",op);
            if(op[0] == 'T'){
                scanf("%d %d",&x,&y);
                unite(x,y);
            }
            if(op[0] == 'Q'){
                scanf("%d",&x);
                int p = find(x);
                printf("%d %d %d\n",p,num[p],time[x]);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值