HDOJ 1215 统计难题(字典树)

统计难题




Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
  
  
banana band bee absolute acm ba b band abc
 

Sample Output
  
  
2 3 1 0
解题思路:直接套字典树模板即可,注意输入的处理。

代码如下:

#include <iostream>
#include <cstdlib>
#include <string>
#include <cstring>
#define MAX 26
using namespace std;
typedef struct Trie {
	Trie *child[MAX];
	int cnt;
};

Trie *root;
void insert(string str)
{
	Trie *current, *newnode;
	int len = (int)str.length();
	if (len == 0) return;
	current = root;
	for (int i = 0; i < len; i++) {
		if (current->child[str[i] - 'a']) {
			current = current->child[str[i] - 'a'];
			current->cnt += 1;
		}
		else {
			newnode = (Trie*)malloc(sizeof(Trie));
			for (int j = 0; j < 26; j++) {
				newnode->child[j] = 0;
			}
			current->child[str[i] - 'a'] = newnode;
			current = newnode;
			current->cnt = 1;
		}
	}
}

int find(string str)
{
	int len = (int)str.length();
	Trie *current;
	if (!len) return 0;
	current = root;
	for (int i = 0; i < len; i++) {
		if (current->child[str[i] - 'a'])
			current = current->child[str[i] - 'a'];
		else return 0;
	}
	return current->cnt;
}
int main()
{
	string str;
	root = (Trie*)malloc(sizeof(Trie));
	for (int i = 0; i < MAX; i++) {
		root->child[i] = 0;
	}
	root->cnt = 2;
	while (getline(cin,str)) {
		int len = (int)str.length();
		if (len == 0) break;
		insert(str);
	}
	while (cin >> str) {
		cout << find(str) << endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值