ACM--贪心--FZU--2111--Min Number

FZU题目地址:http://acm.fzu.edu.cn/problem.php?pid=2111


                                           Problem 2111 Min Number

                                                                                         Accept: 802    Submit: 1587
                                                                        Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

Output

For each test case, output the minimum number we can get after no more than M operations.

Sample Input

39012 09012 19012 2

Sample Output

901210921029 


=============================傲娇的分割线==============================



题意:给你一个数n,和交换次数m,要求经过m次交换之后的最小的数是多少,不能有前导零。

所以就把第一次的交换拿出来单独考虑,首先贪心查找非零的最小值,然后把最小值和第一位交换,每交换一次,交换次数m--。
后面的也是一样的,贪心查找之后位数的最小值,然后和前面的数进行比较,如果比前面的数小就交换。

        

    
    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    int main(){
       char num[2000];
       int i,j,n,m,len,index;
       cin>>n;
       while(n--){
         cin>>num;
         cin>>m;
         len=strlen(num);
         if(m!=0){//m为1的情况要单独考虑
              for(i=0,index=0;i<len;i++){
                   if(num[i]<num[index]&&num[i]!='0'){
                        index=i;
                   }
              }
              //如果后面有数比num[0]小就进行交换
              if(num[0]>num[index]){
                    //交换
                   swap(num[0],num[index]);
                   //交换次数-1
                   m--;
              }
         }
         //从第二位开始找
         for(i=1;i<len&&m!=0;i++){
                //查找最小值
             for(j=i,index=j;j<len;j++){
                 if(num[j]<num[index]){
                    index=j;
                 }
             }
           //交换
             if(num[i]>num[index]){
                swap(num[i],num[index]);
                m--;
             }
         }
         //打印最后的交换结果
         cout<<num<<endl;
       }
        return 0;
    }



参考博客:http://blog.csdn.net/whjkm/article/details/45921931

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值