二叉树的层次遍历

03-树2 List Leaves (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

 就是层次遍历二叉树,然后难点就是如何读入数据的时候把数据截取出来

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int havef[44],queue[33],print_queue[14];
int root,front=0,last=0,print_last=0;//front为有效的第一位,last指的是有效的最后一位的下一位
struct Node
{
    int l,r;
} node[100];
int isdigit(char c)
{
    if(c>='0'&&c<='9')
        return c-'0';
    else
        return -1;
}

int main()
{
    int n;
    memset(havef,0,sizeof(havef));
    scanf("%d",&n);
    getchar();
    for(int i=0; i<n; ++i)
    {
        char temp1,temp2;
        temp1=getchar();
        getchar();
        temp2=getchar();
        getchar();
        int l=isdigit(temp1);
        int r=isdigit(temp2);
        node[i].l=l;
        node[i].r=r;
        if(l>=0)
            havef[l]++;
        if(r>=0)
            havef[r]++;

    }

    for(int i=0; i<n; ++i)
    {
        if(havef[i]==0)
            root=i;
    }
    bfs();

    getchar();getchar();getchar();
    return 0;
}

void bfs(){
    queue[last]=root;last++;
    while(last-front){

        int flag=1;//can print the leaves
       // printf("%d\\\\",last);
        if(node[queue[front]].l!=-1){
            flag=0;
            queue[last++]=node[queue[front]].l;//push
        }
        if(node[queue[front]].r!=-1){
            flag=0;
          queue[last++]=node[queue[front]].r;//push
        }
        if(flag){print_queue[print_last++]=queue[front];}
        front++;//pop
    }
    for(int i=0;i<print_last-1;++i){
        printf("%d ",print_queue[i]);
    }
    printf("%d\n",print_queue[print_last-1]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值