POJ 3032 Card Trick 纸牌顺序

原题 http://poj.org/problem?id=3032

题目:

Card Trick
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4013 Accepted: 2874
Description

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
Three cards are moved one at a time…
This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.

Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

Sample Input

2
4
5
Sample Output

2 1 4 3
3 1 4 5 2

思路:

对于一堆牌,满足条件:第一次移动最顶上的一张到最底下后,面上的是A。拿走A。
第二次移动最顶上的两张到最底下后,面上的是2。拿走2。
以此类推,当移动n次后剩下的就只剩一张n了。再拿走n。
游戏结束。
注意:假如要移动5张,只剩下4张,因为先移动4次后会变成原来的样子,所以只需要移动5%4次。
而我们需要做的就是求出满足要求的这堆牌。

所以这是一道需要用到队列的模拟题。反向模拟就可以求出答案。

代码:

#include <iostream>
#include"string.h"
#include"cstdio"
#include"stdlib.h"
#include"algorithm"
#include"queue"
#include"stack"
using namespace std;
typedef long long int lint;


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        queue <int> q;
        int n;
        scanf("%d",&n);
        for(int i=n;i>0;i--)
        {
            q.push(i);
            for(int j=0;j<i;j++)
            {
                int tem=q.front();
                q.pop();
                q.push(tem);
            }
        }
        stack <int> s;
        while(!q.empty())
        {
            s.push(q.front());
            q.pop();
        }
        while(!s.empty())
        {
            printf("%d",s.top());
            s.pop();
            if(!s.empty())  printf(" ");
        }
        printf("\n");
    }
    return 0;
}

由于本题的n的取值为1到13,所以我们也可以手动算出所有的结果,暴力枚举求解。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值