1255

题目描述

Your task is an easy unit conversion.

There are 5 possible units need to be converted:

1. Hundred = 100

2. Thousand = 1000

3. Million = 1000000

4. Billion = 1000000000

5. Trillion = 1000000000000

You should convert them to base unit.

输入

Muiltple sets of input.

In one set of input, there is only one line which contains a integer (0 <= x < 2^31) and a unit name.

输出

The value after conversion (without leading zero).

样例输入

5 Hundred4 Billion9999 Trillion

样例输出

50040000000009999000000000000

提示

来源

2013东软杯

#include<stdio.h>
int main()
{
    int i,k=0;
   long int n;
    char c[10];
    while(scanf("%ld",&n)!=EOF)
    {
        scanf("%s",&c);
        if(n==0);
   else if(strcmp("Hundred",c)==0)k=2;
   else if(strcmp("Thousand",c)==0)k=3;
   else if(strcmp("Million",c)==0)k=6;
  else  if(strcmp("Billion",c)==0)k=9;
   else if(strcmp("Trillion",c)==0)k=12;
        printf("%ld",n);
        for(i=0;i<k;i++)
        {
          printf("0");
        }
        printf("\n");
        k=0;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值